Tag Archives: libcrypto

2013/01/05

linux安裝套件出現缺少libcrypto-so-6

這個幾乎我裝甚麼都會出現,不知道為什麼linux不直接內建= =
libcrypto.so.6可以安裝openssl後取得,如系統中沒有openssl,就

# yum -y install openssl

安裝即可
如果系統告訴你已經有openssl了,但是還是缺少libcrypto.so.6,那就是系統的openssl太新了
直接到網路上下載0.98版的openssl rpm強制安裝到系統就可以了,正常安裝的話系統會告訴你系統版本比你要裝的新,所以不幫你裝
強制安裝指令:

# rpm -ivh xxxxxxxxxx.rpm --nodeps --force


這樣缺少lib的問題應該就可以解決了。